Potential Delays in Data Sync Between Mend and EHR

Incident Report for Mend

Resolved

This incident has been resolved.
Posted Aug 19, 2025 - 13:01 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 19, 2025 - 12:50 EDT

Investigating

We are currently investigating potential delays in data moving from Mend to connected EHR systems. Our team is actively reviewing the issue and will provide updates as more information becomes available.

Mend Service Team
Posted Aug 19, 2025 - 12:13 EDT
This incident affected: Integration Capabilities (Imports, EHR Integration).