We suggest refreshing the portal if you are experiencing any issues.
Please don't hesitate to let us know if you experience any issues with slowdowns on the Mend portal with the "Tech Support" option, or by emailing us at bestservice@mend.com. We're here to help.
-The Mend Team.
Posted Apr 23, 2025 - 15:49 EDT
Investigating
We are currently receiving reports of minimal slowdowns on the Mend portal, and our tech team is currently investigating.
While not all users are affected, some may experience some slowdowns, or pauses in integration that will resume automatically once the issue is resolved.
If you do experience an issue, we suggest waiting a few minutes and then refreshing the page. We'll be sure to let you know when this is resolved.
If you need any assistance, please feel free to reach out to bestservice@mend.com for support.
We will update this status as we have more information.
- The Mend Team
Posted Apr 23, 2025 - 15:18 EDT
This incident affected: Integration Capabilities (Imports) and Mend Portal (Dashboard).