Notification Delivery Issues

Incident Report for Mend

Monitoring

A fix has been deployed and we are monitoring the situation. Patients will receive notifications from an alternate number.
Posted Jul 03, 2025 - 09:29 EDT

Identified

We have identified an issue with SMS notification delivery. Some patients may not be receiving notifications. We are rolling out a fix which should be resolved by 10am EST.
Posted Jul 03, 2025 - 09:11 EDT
This incident affects: Appointment Reminders & Other Notifications (SMS Text Message Notifications).