Thank you for your patience as we investigated and resolved the issue.
Please don't hesitate to let us know if you have any questions or concerns in the future. You can email us at bestservice@mend.com or contact us with the "Tech Support" option at portal.mendfamily.com.
-The Mend Team
Posted May 12, 2025 - 10:43 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 12, 2025 - 09:49 EDT
Investigating
We are currently investigating reports of issues with Mend digital forms. Some users may experience issues with accessing the content of their forms on the Mend portal.
We are investigating this issue actively and will provide updates as they become available.
If you have any questions or concerns, please feel free to email us at bestservice@mend.com, or select "Tech Support" on the mend portal (portal.mendfamily.com).
Thank you for your patience while we work to resolve this.
- The Mend Team
Posted May 12, 2025 - 09:39 EDT
This incident affected: Mend Portal (Digital Forms).